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Scheduling the Upgrade
All OneStream customers are encouraged to prepare for their Platform version 8.0 upgrade by 
referencing content in the ONECommunity Platform v8+ Upgrades Group and by reaching out to 
their Customer Success representative.

OneStream Cloud customers may initiate Platform version 8.0 upgrade interest by submitting a 
Software Upgrade request through the Service Catalog.  Requests will be routed to the 
corresponding Customer Success representative who will reach out to discuss preparation 
activities required for upgrade readiness.

OneStream self-hosted customers may download Platform version 8 from Solution Exchange, but 
are also encouraged to engage their Customer Success representative to review preparation 
activities to ensure a successful upgrade.
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Requirements
Information Technology professionals responsible for installing, maintaining and supporting 
OneStream, must satisfy the following requirements to best support an upgrade. They must also 
review the requirements and special notes in the Installation and Configuration Guide and 
Release Notes.

IMPORTANT: Platform version 8.0 was developed using Microsoft .NET 6 . As a result, 
all Business Rules must be tailored for .NET 6. For more information, see v8.0 / .NET 6 
Readiness.

 l OneStream 8.0 requires Microsoft .NET 6.

 l OneStream Servers requires IIS 7 or later.

 l .NET Desktop Runtime 6.0.14 or later.

 l ASP.NET Core Runtime 6.0.14 "Hosting Bundle" or later.

 l In each application, complete the Compile all Business Rules and Formulas to verify 
that business rules use the proper syntax.

 l If your applications are referencing any 3rd party DLLs that are not provided by OneStream, 
verify these DLLs are .NET 6 compatible. Contact OneStream Support 
(support.onestreamsoftware.com) to discuss available upgrade options.

 l When upgrading OneStream, ensure  to update the database schema if an update is 
available. We recommend full database backups.

 l Backup the Configuration files in your OneStream Share directory.

 l For additional minimum system requirements, see Hardware and Software Requirements 
in the Installation and Configuration Guide.

 l When implementing SIC with the OneStream application, see Requirements in the Smart 
Integration Connector Guide.
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Before Upgrading
Perform these tasks before upgrading:

 1. Perform a full backup of all OneStream databases.

 2. Download the OneStream installation package from the Solution Exchange:

 a. Log in to the Solution Exchange and select Platform to get the latest version of 
OneStream.

 b. Download the appropriate On-Premise package to get the appropriate setup files for 
the server installation.

 3. Verify the location of the OneStream configuration files:

 a. On a OneStream server, select Start > Programs > OneStream Software > Server 
Configuration Utility.

 b. Right-click the utility and select Run as Administrator.

 c. Select File > Open ASP.NET Configuration File and browse to the appropriate 
location.

 l On web servers: C:\Program Files\OneStream Software\OneStream
WebRoot\OneStreamWeb and select web.config.

 l On application servers:C:\Program Files\OneStreamSoftware\
OneStreamAppRoot\OneStreamApp and select web.config.
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 d. The file opens and displays the path to the XFAppServerConfig.xml and 
XFWebServerConfig.xml configuration files.

 e. Copy and paste the path to the configuration file. You will specify this location during 
the upgrade.

NOTE: This path is commonly set to C:\OneStreamShare\Config

 4. For a backup, copy these configuration files.

 5. Close the file without saving and exit the utility.

 6. Verify the OneStream service account in Internet Information Services Manager:

 a. The service account must be an Admin ID or in the IIS_IUSRS Group, Performance 
Log User and Performance Monitor Users group. The ID is required for queuing and 
CPU monitoring.

 b. On each OneStream server, select Start > Control Panel > Administrative Tools > 
Internet Information Services (IIS) Manage.

 c. Expand the server and select Application Pools. This displays application pools to 
the right. The OneStreamAppAppPool and OneStreamWebAppPool service 
accounts display in the Identity column. Note the Windows account and password as 
you will enter them in IIS after the upgrade.

 7. Verify the availability of the OneStream Application Server where:
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 l The OneStream Database Configuration Utility is installed: On each OneStream 
application server, click Start > Programs> OneStream Software and verify that 
the OneStream Database Configuration Utility is installed.

 l OneStream is installed: On each OneStream application server, 
Start > Programs> OneStream Software to verify that OneStream is installed. 

 8. Install ASP.NET Core Runtime 6.0.14 "Hosting Bundle" or later found here.

 9. For all client machines running OneStream, install .NET Desktop Runtime 6.0.14 or later 
found here.
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Upgrade System Components
Perform the tasks in the following sections - in order, to upgrade the complete OneStream system.

Stop the OneStream Application Pools
 1. On each OneStream server, launch Internet Information Services Manager by selecting 

Start > Control Panel > Administrative Tools > Internet Information Services (IIS) 
Manager.

 2. Expand the server and select Application Pools. This displays all pools to the right.

 3. Right-click these pools and select Stop:

 l OneStreamAppAppPool

 l OneStreamWebAppPool

 l OneStreamMgmtAppPool

 4. Repeat these steps for each server in the environment.

 5. Close any open OneStream Configuration Utilities.

Uninstall OneStream Servers
 1. Select Control Panel > Programs and Features > Uninstall a Program and locate the 

OneStream Servers component.

 2. Right-click OneStream Servers and select Uninstall.

Uninstall OneStream Client API
 1. Select Control Panel > Programs and Features > Uninstall a Program and locate the 

OneStream Client API component.

 2. Right-click OneStream Client API and select Uninstall.
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Re-Install OneStream Servers on an 
Application Server
This is the primary installation package that performs a complete server setup, including the web 
server, application server and all utilities. You can perform a custom install to choose the 
appropriate server components.

 1. Browse to the OneStream Servers package, right-click OneStreamServers-#.msi and 
select Install to run the server installation.

 2. Click Next on the landing page and accept the License Agreement.

 3. Specify the directory where the software was previously installed and click Next.

 4. Select Custom and click Next.

 5. On Select Features, choose Application Serverand Server Configuration Utility and 
click Next.

NOTE: Choose the Database Configuration Utility and Upgrade Assistant 
Utility if the application server is the server where the Database Configuration 
Utility was previously installed.

 6. Click Install then Finish.

Re-Install OneStream Servers on a Web 
Server

 1. Browse to the OneStream Servers package, right-click OneStreamServers-#.msi and 
select Install.

 2. Click Next and accept the License Agreement.

 3. Specify the directory where the software was previously installed and click Next.

 4. Select Custom and click Next.
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 5. On Select Features, choose Web Server and Server Configuration Utility and click 
Next.

 6. Click Install then Finish.

Re-Install OneStream for Desktop
 1. Browse to the OneStream package, right-click OneStreamDesktop-#.msi and select 

Install.

 2. Click Next and accept the License Agreement.

 3. Select Custom and click Next.

 4. Select the directory where the software was previously installed and click Next.

 5. On Select Features, select all options and click Next.

 6. Click Install then Finish.

 

Upgrade the Framework and Application 
Databases
Before performing these steps, have a database administrator back up all OneStream databases.

 1. On the OneStream application server with the OneStream Database Configuration Utility 
installed, select Start > Programs > OneStream Software > OneStream Database 
Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Right-click OneStream Framework Database and choose Upgrade Database Version.

NOTE: If this is disabled, an upgrade is not required.

NOTE: If you get an error, check the log for details: C:\Program 
Files\OneStream Software\XFDatabaseConfig\Log
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 4. Confirm the upgrade.

 5. Repeat the upgrade for each Application database and the Framework database until 
the option is disabled. This will indicate you have updated to the current version.

Run the Upgrade Assistant Utility
This is an additional step for version 8.0 and must be run after the Framework and Application 
Databases have been upgraded. Specifically this version of the Upgrade Assistant Utility will 
convert any legacy reports that were stored in CodeDOM format to now be stored as XML.

 1. On the OneStream application server with the OneStream Upgrade Assistant Utility 
installed, select Start > Programs > OneStream Software > OneStream Upgrade 
Assistant Utility.

 2. From the command line enter: 

xfupgradeassistant -c C:\OneStreamShare\Config\XFAppServerConfig.xml -t 
ReportLayoutBytes -v -update

NOTE: C:\OneStreamShare\Config is the default path to the configuration 
file. You must update this path if it has been modified for your environment.

 3. Enter exit to close the utility.

 4. Restart IIS.

Update the ASP.NET Configuration File
The ASP.NET Configuration file (appsettings.json) must  be updated on every server / folder as 
outlined below:

 l Application server

 o C:\Program Files\OneStream 
Software\OneStreamAppRoot\OneStreamApp\appsettings.json

 l Web servers:
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 o C:\Program Files\OneStream 
Software\OneStreamWebRoot\OneStreamWeb\appsettings.json

 o C:\Program Files\OneStream 
Software\OneStreamWebApiRoot\OneStreamWebApi\appsettings.json

 l BUX server:

 o C:\Program Files\OneStream 
Software\OneStreamWebUIRoot\OneStreamWebUI\appsettings.json

 1. On each OneStream server, launch the OneStream Server Configuration Utility by clicking 
Start > Programs > OneStream Software > Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Choose File > Open ASP.NET Configuration File and browse to the appropriate location 
from the folders above.

 4. Select the appsettings.json file.

 5. When the file opens, copy the directory path of the configuration files.

NOTE: This path is commonly set to C:\OneStreamShare\Config

 6. Enable HTTP and Enable HTTPS are enabled by default.  Change when applicable.

NOTE: Clear Enable HTTP when SSL is enabled or clear Enable HTTPS 
when SSL is not enabled.

 7. Save and close the file.

 8. Repeat these steps on each web and app server in the environment.
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Update the Configuration Files
 1. Open the Application Server Configuration file and select File > Save.

 2. Close and re-open the same file.

 3. In Database Server Connections, select the ellipsis and update the command time-outs 
for the OneStream Database Server connection:

Short = 90    *must do

Large =900 (minimum or 900)

 4. Select File > Save and close the file.

 5. Open the Web Server Configuration file.

 6. Select File > Save and close the file.

Update and Configure IIS
 1. On each OneStream server, open the OneStream Server Configuration Utility by clicking 

Start > Programs > OneStream Software > Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Choose Tools > Configure IIS.

 4. In Configure IIS, specify the following:

 a. For Web Site Name, enter the name of the OneStream IIS Website to update.

 b. The OneStream App Server, and Web Server sites.

 5. Select Update IIS Default Settings.

 6. Select options to update IIS for the appropriate websites:

 a. Use Web Server Settings: Specify the Web Server site.

 b. Use App Server Settings: Specify the App Server site.
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 c. User Account Type: Specify Custom Account, then enter the user name and 
password of the OneStream Service account.

 7. Click Update IIS Settings then OK.

 8. Repeat these steps to set the appropriate IIS settings for the application pools in IIS.

 9. Click Reset IIS.

Test the Login
 1. Navigate to the OneStream Windows App URL:

 l On Prem: http://<webserver>:50001/OneStreamWeb/OneStreamWindowsApp.aspx

 l Cloud: https://<customer>.onestreamcloud.com/onestreamweb

 2. Click Opento launch the Click Once Windows app.

 3. Confirm that you can log in.

 4. From Application, select System Administration then click Connect.

 5. Select System > Tools > Environment to identify the application servers and their status.

 6. Verify that each server is active.

Verify the Application
 1. Compile all business rules, ensure  to:

 l Right-click the grid and export any errors for analysis using an Excel file format.

 l Apply updates as needed.

 2. Download and import the Standard Application and Standard System Reports from the 
MarketPlace portal on the Solution Exchange.
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Version 8.0 / .NET 6 Readiness
Upgrading your OneStream Platform to version 8.0 or later requires .NET 6 for full compatibility.

This Platform release includes updates and enhancements to the Business Rules compilerto 
improve syntax detection. Administrators must resolve these errors to  compile business rules 
fully. Warning messages identify line items that will function, but you should update them to 
support the latest compiler’s requirements. Resolving  these warnings varies. You may be able to 
use a provided replacement function or change a function’s properties.

Business Rules
For more information,  visit the Platform v8+ Upgrades page on ONECommunity.

Custom DLLs
If your implementation / business rules reference any custom DLLs that are not provided by 
OneStream, these DLLs must be .NET 6 compatible. Contact OneStream Support 
(support.onestreamsoftware.com) to discuss available upgrade options.

ERPConnect (SAP)
ERPConnect45.dll enabling connection to SAP systems is no longer available in Platform 8.0. A 
newer version ERPConnectStandard20.dll is available through  the download "DLL Packages" 
from the Platform page of the Solution Exchange.

On-Prem Customers:

 1. Download ERPConnectStandard20.dll file to your integrations folder.

 2. Install the required Visual C++ 2013 Runtime.

 3. Download and copy SAP NetWeaver RFC Library DLL (sapnwrfc.dll) to the integrations 
folder.
See  Theobald Software ERPConnect Requirements for more information.

 4. Modify your business rules to use the ERPConnectStandard20.dll.
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Cloud/SaaS Customers: ERPConnect is available through  the Smart Integration Connector 
(SIC). See  ERPConnect section of the SIC Guide for installation details or contact OneStream 
Support (support.onestreamsoftware.com) to discuss morel upgrade options.

Smart Integration Connector
Smart Integration Connector is required for OneStream Cloud integration with local customer data 
sources when using OneStream Platform version 8.0 or higher.  VPN is no longer supported with 
version 8.0 or higher and will reach end of service for Platform versions prior to version 8 on 
August 31, 2024.

Authentication
Cloud Customers: OneStream IdentityServer is required for OneStream Platform 8.0.

Self-hosted Customers: No changes necessary. Legacy Authentication support is continued.

.NET 6 Desktop Runtime and ASP.NET 
Runtime
Download the .NET Desktop Runtime 6.0.14 or later installer here.

Download the ASP.NET Core Runtime 6.0.14 "Hosting Bundle" or later installer here.

VBA Changes
ProcessSSOAuthenticationAndCreateToken is no longer supported as an authentication option 
from VBA scripts. See Visual Basic for Applications (VBA) Procedures for additional details. See 
Visual Basic for Applications (VBA) Procedures in the Design and Reference Guide for additional 
details.

Client API Changes
Client API is no longer provided with Platform version 8.0 or higher.  OneStream recommends 
Task Scheduler or the REST API to replace existing Client API use cases.
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Tiles Page
The ClickOnce journey is enhanced to launch the application with a single click of the Open 
button while eliminating the tiles page. For more information, see Installation Using ClickOnce in 
the Installation and Configuration Guide.For more information, see Installation Using ClickOnce in 
the Installation and Configuration Guide.

Help Documentation
Help documentation has moved from within the application to 
https://documentation.onestream.com. Clicking the in-app help icon routes you to this site.

Business Rule Groups
In version 8.0 the default for new Business Rule Access or Maintenance Groups is the 
Administrators group. This default can be changed by the Server Configuration Utility.

MarketPlace Solution Compatibility
The following MarketPlace Solutions are compatible with OneStream Platform version 8.0.

MarketPlace Solution Version

Administrator Solution Tools PV620 SV101

Application Control Manager PV710 SV100

Capital Planning PV620 SV102

Cash Planning PV620 SV102

Cloud Administration Tools PV600 SV100

Contract Compliance PV620 SV102
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MarketPlace Solution Version

Dimension Comparison PV600 SV100

Excel Add-in Installer PV710 SV100

File Explorer Manager PV650 SV102

Financial Close PV710 SV201

Guided Reporting PV600 SV102

Help Desk PV640 SV100

Marketplace Solution Tools PV720 SV100

Metadata Builder PV520 SV101

Model Maker PV680 SV201

Parcel Service PV630 SV100

People Planning PV620 SV103

Predictive Analytics 123 PV620 SV101

Provision Request Manager PV440 SV104

Reporting Compliance PV620 SV103

Sales Planning PV620 SV102

Sample Templates  PV600 SV100

Scenario Analysis 123 PV530 SV100
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MarketPlace Solution Version

Security Audit Reports PV620 SV100

Standard Application Reports PV610 SV201

Standard Cube View Styles PV410 SV100

Standard System Reports PV430 SV102

System Diagnostics PV620 SV202

Table Data Manager PV620 SV100

Task Manager PV660 SV102

Tax Provision PV620 SV200

Thing Compliance PV620 SV102

Thing Planning PV620 SV101

XML Security Remover PV410 SV100
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Help and Miscellaneous
Internet Explorer End-of-Use
When using ClickOnce, it must be invoked using Microsoft Edge. For more information, see 
ClickOnce in the Installation and Configuration Guide.

More  details for IE end-of-use details are as follows:

As of July 2022, if you have an Internet Explorer ClickOnce shortcut to the OneStream Desktop 
Client application, it will not launch the application of any version when IE is disabled inside  your 
organization. Starting with 7.0, newly created shortcuts will be created using Windows 
PresentationHost.exe. Upgrading to 7.0 will not automatically update existing shortcuts. You must  
manually create new ones or edit existing ones. To update an existing shortcut of any OneStream 
platform version, follow these steps:

 1. Right-click on the existing desktop shortcut and go to Properties.

 2. Copy and paste the text in the Target field into the notepad.

 3. Replace this section “C:\Program Files\Internet Explorer\iexplore.exe” with 
C:\Windows\System32\PresentationHost.exe-launchApplication (note that the “ “ are 
removed).

 4. Copy and paste the whole text into the target field inside the shortcut's properties, click 
Apply, then click OK.

You will not be able to view embedded external web pages inside OneStream when IE is disabled 
inside  your organization. Starting with 7.0, the external web pages will be embedded using the 
Microsoft Edge WebView2 runtime control. Microsoft automatically installs the WebView2 runtime 
on Windows 10 machines. You can verify if the component is installed on your machine through 
Add or Remove Programs. It can also be downloaded directly from Microsoft.

Once IE is disabled within your organization, embedded web pages will no longer render inside  
OneStream on versions 6.8 and older, even if you have WebView2 installed. If your application 
uses features that embed external web pages, usually through properties that allow pointing to a 
URL, an upgrade to 7.0+ will be required with the WebView2 runtime control. Key OneStream 
features that enable embedding external web pages:
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 l Dashboard component Web Content

 l Dashboard component File Viewer

 l Dashboard component Button

 l A drill back Business Rule in Transformation Rules Connector
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