Odd Login Screen Displayed

New Contributor II

New install of 7.3.1.

WebServer on one machine.  AppServer on another.

When I attempt to access any of the WebServer pages, I am prompted with a very odd login page.

The only fields on this page are a missing header_logo,  username/password fields and a login button.

I tried to log in with the default Administrator password and it says "The password was reset and needs to be changed."  I have not logged in to OneStream yet, so the default password should not have changed.

Since I cannot access OneStream, I am not able to reset the password.

I have no idea where to start looking to resolve this one.

Any help would be appreciated.



Valued Contributor

Hi there!
I do not know how you try to log in and if you have the correct client version. FYI, here is the URL to install your OS http://url:50001/onestreamweb/OneStreamWindowsApp.aspx update with your URL but keep the rest of the path.

Are you using SSO or Native Authentication? Does another user have the same issue?

Connect with me on:
LinkedIn: https://www.linkedin.com/in/nicolas-argente/
Website: https://aiqos.io
If you want to lift yourself up, lift up someone else.

The URL you mentioned is the URL I am using.  I have also tried OneStreamXF.aspx.

I am not able to download the Windows App because I cannot get passed this weird login screen.  I am using native login, because I am not able to configure SSO yet.

Additional note: I am able to run the OneStreamDesktop.application file from the ClickOnce\OneStreamDesktop folder.  I get the correct screen.  I have not tried connecting yet.  I assume this is a permissions issue.  I am just not sure where.

New Contributor II

Good Morning.

I have additional information that may help get this issue resolved.

I changed the IIS application pool to use NetworkService and the "odd" login screen became a normal looking login screen.  However, I am still not able to log in.

Here is what is happening:

When I use http://[onestream]:50001/OneStreamWeb/OneStreamWindowsApp.aspx, I get redirected to OneStreamWeb/NativeLogin.aspx.  This screen prompts for a username/password.  So, I enter the only username/password I know (Administrator/OneStream) and I get a message that says "Unable to log on user 'Administrator'.  The password was reset and needs to be changed."  I have no idea how to change the password, since I cannot log in to OneStream.  I have tried other URLs and they all seem to redirect me to this NativeLogin page.

Any help would be appreciated.

Hi Raymond, 

After you get the message saying the password needs to be changed, and click ok, do you get the password change window?


You should be able to change the password this way.



Thanks for the reply.

Unfortunately, I do not get to the screen you show above.  I get the message about changing the password but it goes right back to the login screen, not the screen that allows me to change the password.

This was a permissions issue in IIS.  When I changed the identity for the AppPool to a service account that was a little more "open", things worked as expected.  If I can figure out what one service account has over the other, I will be sure to post my findings here.  Thank you.

New Contributor

Using a service account with more "open" permissions worked but is not the answer.

The answer turned out to be the user IIS was using for anonymous.

In a default installation, IIS sets the anonymous user as IUSR for a website.

To resolve, here are the steps I followed:

Open IIS Manager

Select the WebSite.

Open Authentication

Right-click Anonymous and click Edit.

Change the user to be "Application Pool Identity".

Save and restart.

This resolved my permissions issues.