Square Brackets in Member Filter (Text Property)

vignesh
New Contributor II

Hi Experts,

I am trying to use a member filter based on the Text property. Here are the sample text property values:

Member1  = PASSTHRU~[False]|IPL~[False]

Member2  = PASSTHRU~[True]|IPL~[False]

I wanted to filter the members that have " PASSTHRU~[True] " in the text property, i tried the filter below but it returned no results:

U4#Top.Base.where(Text8 Contains PASSTHRU~[True])

I do get results if i use U4#Top.Base.where(Text8 Contains PASSTHRU~), but as soon as i add  " [ " character, it doesn't pull any members. 

Any suggestion would be helpful.

I tried all the below formats, nothing worked:

U4#Top.Base.where(Text8 Contains 'PASSTHRU~[True]')

U4#Top.Base.where(Text8 Contains [PASSTHRU~[True]])

U4#Top.Base.where(Text8 Contains PASSTHRU~[[True]])

3 REPLIES 3

AK
New Contributor III

I tried this, and it worked for me. It appears that ~[ might be associated with a specific system keyword. However, I could not find any documentation around this.

AK_0-1716911525374.png

 

 

 

vignesh
New Contributor II

@AK There are cases where text values contains 'True' in other places, so it wont work. 

 

Member5  = PASSTHRU~[True]|IPL~[True]

KarlT
Contributor

The "[]" are used in member filters to surround member names (particularly where there are spaces or special characters are used in the naming). Therefore i suspect the member filter automatically ignores these.

I think the question is do you need the square brackets, or could they simply be removed. Alternatively the "{}" should work for you.