Advanced Chart Secondary Y Axis

New Contributor III

We are trying to create an advanced chart using a secondary y axis and are running into issues.  We referenced blog which explains how to code the business rule.  However, there is no place within the chart to reference the cubeview and when we run the dashboard, we get an error message stating the data adapter type does not match the chart type.  Any solutions or if there's any document we can refer to which would show end to end flow around the cubeview, data adapter, business rule, and chart?  Below are screenshots of our data adapter, chart, and dashboard error.






Community Manager
Community Manager

You can't mix and match Cube Views and Dashboard DataSets; the Data Adapter linked to the chart must be pointed at the DDS business rule, which will provide all the data.

In the example you linked, basically there will be two data adapters: one of type Cube View (let's call it "daCV") and one Method / Business Rule ("daBR"). The chart is linked exclusively to daBR; on execution, daBR will invoke daCV and wrap the result to apply the changes mentioned.

Thank you for the help!  We created a new data adapter that is Method which should run the Business Rule and one that is Cube View the Business Rule points to.  The Cube View data adapter runs as expected, but we aren't sure we setup the Method data adapter properly.  Is this the right coding for method query?  When we run the Business Rule data adapter, we don't get any results.


Try with square brackets instead of single quotes, around TTM_EBITDA. The rest looks fine. If it still doesn't work, you'll have to troubleshoot the rule... Looking at the post you linked, I'd make sure your original series is actually populated before it's modified, because all those parameters to FillUsingCubeViewDataAdapter look tricky to get right.

I updated the method query to have square brackets around TTM_EBITDA, but that still provided no luck.  I ran the Cube View Data Adapter which does result in data, but the Method Data Adapter does not.  I'm thinking the issue lies in the way we set up the Business Rule.  The only thing we added was a comment which I wouldn't think would cause issues on the business rule. 



Try logging whether that oSeriesCollection actually contains anything, after that Fill call. If it's empty, nothing that follows will do anything. The parameters it requires can be tricky to get right:


I'd look in particular at the Workspace name, since things can get hairy there in recent releases.