CubeView - Allow Sparse Row Suppression

New Contributor III


We have created one Cube view with using "True (but determine sparse rows using other columns)" option under Allow Sparse Row Suppression in Column level and gave "True" under Allow Sparse Row suppress in Cube View properties level as we have used Nested members in Rows with Parent.Base member combinations in Member filter level. When we run the report, it suppresses the rows as per other column even though formula column is having data also.


Ex: Cube view created with 2 columns

  1. 1st column with Account1
  2. 2nd column with calculation GetDataCell(A#Account2 + A#Account3)

Row is getting suppressed if Accout1 doesn’t have data even though Account3 is having data also. If we remove above suppression options report throwing an error as exceeding the rows limit since hierarchies are big. Could you please let me know if there any option we can use to show the data at 2nd column level in above scenario


Valued Contributor

The issue is the formula.  You are using an account which is what the suppression keys off of.   The formula is not considered when rendering the data set.    You would have to show account 1.  Account 2 and account three. And then do the calculation.   You could hide the columns if you wanted.    

New Contributor III

We have tried to bring all the columns and did the suppression. But we got the same results, the suppression is being happened on all columns irrespective of Zero/Non-zero/Blank/Non-blank rows.
Are we missing something? can you help us to fix this issue.