Open DataExplorer from Dashboard Button

ghoang
New Contributor II

Has the syntax for Navigation Action changed to include workspace name in .v8?

We have buttons that open up cubeviews that have been working fine in the past, but now don't work since we upgraded to .v8.1. 

Others actions like open up workflow or other dashboards work fine. Just DataExplorer that's not working.

TIA

ghoang_0-1713802894807.png

 

 

2 ACCEPTED SOLUTIONS

Krishna
Valued Contributor

@ghoang  - Hmm... As far I know the syntax did not change. You can create a support ticket and verify because it was working in V7.4. Please keep me posted on the solution. Thanks

 

Krishna_0-1713811358509.png

 

Thanks
Krishna

View solution in original post

JackLacava
Honored Contributor

Yeah, it looks like something is broken. Please open a case with Support to validate it.

As a temporary (and awkward) workaround, you can use XFPage=CubeViews:MyCubeView . It will open the CV design page, and you can run it from there. I know this might not be viable for users who don't have access to the design page.

View solution in original post

8 REPLIES 8

Krishna
Valued Contributor

@ghoang  - Is part of the default workspace or it is a new workspace? Also check the below Post.

Solved: Is there a list of the XFPages options for a dashboard component? - OneStream Community (one...

 

Thanks
Krishna

ghoang
New Contributor II

It's a default workspace. We have had it for a while in 7.4 and it's been fine, now it's not when we're in 8.1

ghoang
New Contributor II

Also I checked out the post you attached. That post explains opening a "page", the error I have is related to opening DataExplorer / Cubeview.

Krishna
Valued Contributor

@ghoang  - Can you try XFPage=CubeView:MyCubeView ?

Thanks
Krishna

ghoang
New Contributor II

I just tried it, didn't work. Nothing happened when I click on the button.

Krishna
Valued Contributor

@ghoang  - Hmm... As far I know the syntax did not change. You can create a support ticket and verify because it was working in V7.4. Please keep me posted on the solution. Thanks

 

Krishna_0-1713811358509.png

 

Thanks
Krishna

JackLacava
Honored Contributor

Yeah, it looks like something is broken. Please open a case with Support to validate it.

As a temporary (and awkward) workaround, you can use XFPage=CubeViews:MyCubeView . It will open the CV design page, and you can run it from there. I know this might not be viable for users who don't have access to the design page.

ghoang
New Contributor II

Thanks. We'll enter a ticket. The workaround won't work for us unfortunately, because most users don't have access to the design page.