Data Integration with source table

New Contributor


we are currently in the process of Finalizing a Data integration process (via connector) between some temporary staging tables created in the Onestream application (on cloud), but when i try to perform the final step to load the data, the system always returns me the message that allof the rows i'm importing are NON-NUMERIC. Obviously that's not the case. the source table amount column is a numeric format and the amount field in the source field is being mapped to the Amount field in the data source. 


Did Anyone experience this?




Contributor II

Hi, I haven't had that issue before, but the first thing I would check are the numeric settings of the Amount field in the connector data source. For example, is the Decimal Indicator option set to "."?

New Contributor

Thanks for your Answer. I did check the decimal separator and it's correctly set to ".".

Just for testing i tried removing all of the decimals, and also tried fixing the value in the source query to "100". 

In the log file i can correctly see that it takes the 100 as 100.00, but still it tells me the amount is non numeric.




From your screenshot I can see you have some Attribute Value dimensions too, like Value10 or Value11. Are those all correctly mapped to numeric fields? (it is fine if they are not mapped to any source column, but they should not be mapped to non-numeric columns)

New Contributor

Hi, i checked and there was no column assigned to the Value columns. i also tried assigning the same Amount value but there was no change...

Hi MarcoG. Did you ever figure out the issue? We're facing the same.


I can't see from the log if you have lines that are valid? If you have valid and non-valid lines, then I would check the content of a "bad" and "good" line, to see the difference

New Contributor

Thanks for the feedback. 

No line is valid, it seems like it's not line related but it's something on the whole dataset or the datasource setting.

i also tried fixing the value to 100 on the query itself but there was no change. 




Sounds like the Amount field is mapped wrongly - can't you check in a Data Adapter how the data actually looks like?

Community Manager
Community Manager

I would check the way you're building the connector, it might be that the DataTable you're returning for some reason is using a textual type for columns mapped to numeric fields. 

Also, since you have Attribute Values, try reducing variables: set all numeric values to Static value 1 until the import succeeds; then switch them back to actual fields one by one, to figure out which field actually breaks.