cancel
Showing results for 
Search instead for 
Did you mean: 

Matrix load using a connector data surce

OSAdmin
Community Manager
Community Manager
Originally posted by Vignesh Mohan

Hi,

I am trying to import data from Snowflake using JDBC / ODBC connection. In the Snowflake side a view has been created with the correct data set for the import. The connectivity as such works as I tested the same through the Data Adapter in the Dashboards. I am able to retrieve data for the same query that I am using in the connector rule using this test method. The data structure type in the data source section in OneStream is setup as Matrix data as I need some of the column names to be mapped to the Accounts dimension members. When I run the data import from the workflow, I get the following error,

No valid DataKeys (Scenario / Time) found in data source.  Review the source data load processing log and check one-to-one transformation rules to ensure that you have created proper Scenario and Time dimension rules for this data source.

All dimensions are mapped appropriately in the transformation rules. I am also using few attributes to import the data and I have leveraged them in the transformation rule for composite mapping for few dimensions.

Thanks in advance.

Regards,

Vignesh

1 ACCEPTED SOLUTION

OSAdmin
Community Manager
Community Manager
Originally posted by Vignesh Mohan

This issue is now fixed. The issue was because of the format of workflow year and period that was sent as parameter to the query that retrieves the data from the source. In our setup the periods are setup as 2019M1, however at source the period is 01. Just had to make some minor tweaks in the connector rule to get the formatting correct.

View solution in original post

1 REPLY 1

OSAdmin
Community Manager
Community Manager
Originally posted by Vignesh Mohan

This issue is now fixed. The issue was because of the format of workflow year and period that was sent as parameter to the query that retrieves the data from the source. In our setup the periods are setup as 2019M1, however at source the period is 01. Just had to make some minor tweaks in the connector rule to get the formatting correct.

Please sign in! OSAdmin