Process Cube Failed unless Calculation Definition is configured in 7.4.1

Wei
New Contributor III

Hello OS Team,

I am testing a few things in the latest version 7.4.1 and noticed something changes from 7.3 but was not mentioned in the release note - so just want to double check in case I missed something:

For this Import step, I don't have anything configured in "Calculation Definition", in 7.3 I am able to Load and Process cube without any error, however in 7.4 - the "Load And Process Cube" only did the "Load" and when clicked on "Process Cube", I am seeing the following error.

I actually like this change - could you please let me know whether this is indeed one of the changes in 7.4?

Many thanks

Wei

WF_ProcessStep_Error.png

4 REPLIES 4

JackLacava
Moderator
Moderator

As far as I can see, this is not an explicit change: i have a 7.4 with an upgraded application and, as long as there is some data to load, "Load and Process Cube" seems to work even withouth calculation definitions. However, an isolated Process task on a Review profile without definitions seems to fail.

There is probably some underlying nuance that we're not grasping here, so you might want to engage Support to get answers - and post them here for good karma 😊

Wei
New Contributor III

Thanks Jack - my app is a newly created app in 7.4, not upgraded. Could you please confirm when you run "Load and Process Cube", what is the message in the log? Does it say "2 processes completed"? I can also run that in my app, without the error, but the log message says: " 1 process completed", not 2 (which should be: Load and Process) - then when I click on "Process Cube" button after that, it failed. 

Thanks

Wei

When doing it as part of a Base Input profile "Import, Load, Process", the popup says "1 background process completed" and the Task Activity Log contains this (drilling from top):

JackLacava_0-1683277601910.png

If running "Process Cube" in isolation as part of that same workflow step, i get one undrillable line but no error:

JackLacava_1-1683277698321.png

 

Wei
New Contributor III

Thank you, Jack - will check again with the upgraded application to confirm.

Wei