Workflow error on load step - Value cannot be null. Parameter name: type

New Contributor II


While trying to import data through a workflow from a *CSV file I am getting the error from below when performing the Load step of the workflow: These are the only details of the error, in the Task Activity there are no relevant details for this error.

This seems to be a generic error. Could this be related to the workflow setup or is it something else?

Thank you.




Contributor III

You can enable detailed logging in the WFP and then run it . Check for more details in the child step in Task Activity.


New Contributor II

Hello @OS_Pizza , thank you for your reply. The detailed logging is enabled but the details from the task activity do not seem relevant for the error:



Is there any other place I could check? Thank you.

Community Manager
Community Manager

I've seen that error popping up when I forgot something fundamental - like a transformation rule group for a dimension type missing in the TR profile, or an unmapped/mismapped dimension in the DataSource.

Hello @JackLacava , @mitrad, thank you for your replies. Unfortunately, I tried making different changes to the data source and transformation rule but the same error kept appearing. I will try to disable the dimensions from the cube and maybe load one by one and see where the error starts appearing if it is data source related.

New Contributor III

I think this is related to DataSource set up under Application tab.