cancel
Showing results for 
Search instead for 
Did you mean: 

null from Dashboard Data Adapter via REST (GetAdoDataSetForAdapter)

dbeavon
New Contributor III

I'm getting this content back from the REST calls to a data adapter:

null

 

Here are some headers:
StatusCode: OK, Content-Type: application/json; charset=utf-8, Content-Length: 4

 

There is no failure, just a "null" content where JSON should be. There is nothing in the onestream error log.

It seems to happen a large percentage of the time (20% or so).  What should I do to investigate?  Is it ever the expected behavior that the API will return HTTP-OK with the word "null"?

Using version 6.5.0.12623.

 

 

 

1 ACCEPTED SOLUTION

dbeavon
New Contributor III

We fixed it.  The OneStream admin restarted IIS.  

 

Either way it is unhelpful for the API to return HTTP-OK with the word "null", and nothing else.  Seems like the underlying exception is probably being suppressed and replaced/obscured.  I suspect there is a onestream bug within the Dashboard Data Adapter.

View solution in original post

2 REPLIES 2

dbeavon
New Contributor III

I have a pattern.  It seems to send me null on every other request.

The adapter is type "mehtod" with method type "BusinessRule".

I added some logging in there and it doesn't appear that the Business Rule is even starting.  It is a "Dashboard Data Set".

dbeavon
New Contributor III

We fixed it.  The OneStream admin restarted IIS.  

 

Either way it is unhelpful for the API to return HTTP-OK with the word "null", and nothing else.  Seems like the underlying exception is probably being suppressed and replaced/obscured.  I suspect there is a onestream bug within the Dashboard Data Adapter.