Retaining Previous Value of Dashboard Button Parameters While Opening in WorkFlow

VENKAB05
New Contributor II

Hello Everyone,

I am having issues retaining the previously selected parameter value in the dashboard, which is linked to a button component.

I have a dashboard that has a parameter to pick an entity, and this parameter is attached to a button component in the dashboard. Let's say I run the dashboard and pick an entity X from the button for the first time. If I try to open the same dashboard again and again, the same entity X gets displayed by default, which is expected.

Now the problem is when I attach this dashboard to a workflow. From WorkFLow, the entity that I picked for the first time in Dashboard is not getting retained when I open the same dashboard multiple times from through WorkFlow.

Is this behavior expected, or am I missing something here? It would be great if anyone could help here.

Thanks,

Balaji V

12 REPLIES 12

phollander
New Contributor III

Hi Balaji,

How did you set up the parameter behind the button? Is this a member dialog/list/BR-driven parameter, is the entity selection in related to get a list of workflow assigned entities or possibly related to any of the calc-definition assigned workflow entities? Also, did you assign the Dashboard to a workflow step directly, as part of a Form template or did you make it available through any of the Dashboard Profile settings on the workflow step?

From what I have seen, Onestream stores the selected parameter values of a Dashboard in a temporary file on your computer. Only when you have written a specific BR to load upon opening the dashboard to clear/change these values, Onestream should pull the latest parameter values from that temporary file. If the parameter is workflow-dependent, it could be that the list of parameter values changes when you switch to another workflow profile. In that case, the parameter value is technically still preserved, but it may present it as an empty value on the dashboard.

Maybe you can clarify the issue with some screenshots?

Best regards,

Paul

VENKAB05
New Contributor II

Hi Paul,
Thanks for the response.

Parameter setup as Member Dialog in a Button.
I haven't assigned any Entities to that WorkFlow
Dashboard is added to WorkFlow through Form Template.

So i'm currently in 2nd Form. Lets say i choose Entity X and submit some data. Now i am going back to 1st form and then coming back to the 2nd form, i would expect the same Entity X to be displayed but that's not happening. It works fine when i run the dashboard directly, issue is only while accessing Dashboard through Workflow.

VENKAB05_1-1701434910112.png

 

Works for me, dude (version 7.4.2). Button:

JackLacava_0-1701442491252.png

Parameter:

JackLacava_3-1701442561715.png

Label to show the parameter:

JackLacava_4-1701442583903.png

The label shows the last-selected value for the parameter, after i switch back and forth through forms and even periods.

You might have some Dashboard Extender or XFBR interacting with that parameter.

 

VENKAB05
New Contributor II

Hi Jack,

Thanks, Just to confirm..Does it work even while doing it through WorkFlow ?

Yeah, that's what I meant when I wrote "switching back between periods"

JackLacava_0-1701459959882.png

 

phollander
New Contributor III

I would check two things:

  • As mentioned by Jack, is there a dashboard extender running on the "Load Dashboard Server Task" or possibly an XFBR within the parameter that you set up?

  • If this is not the case, try to navigate to the following directory path on your local Windows Explorer and confirm if you can find the following .txt file:

    Forms_CustomSubstVars_<UserName>_<AppName>_<DashboardName>.txt
  • If the .txt file is available, open it and you should be able to identify what value is stored for the parameter. Now try opening up the dashboard through the workflow form, change the parameter to reflect a different value. Once it is has processed your action, click away and refresh the .txt file.

Has the parameter value changed in the .txt file? Has it changed the Date Modified in the file after you changed the parameter value? Reason for checking is to rule out that Onestream somehow does not have the appropriate Write access to the folder where the parameter values are preserved. I have never come across this myself, but it would be good to rule this out.

Regards,
Paul

VENKAB05
New Contributor II

I can see the text files..

The Dashboards which has issue are not updated, while others are updated with the right param value. 

Thanks for throwing light on this by sharing the text file details, this clearly indicates something going wrong with specific dashboards.

Hi Paul,

Thanks for this detail (just reading this thread with interest!).

Sorry for the dumb question but when you say navigate to the directory on Windows Explorer (Forms_CustomSubstVars_<UserName>_<AppName>_<DashboardName>.txt) - could you confirm exactly where you are finding that? (Maybe a quick screenshot if possible?)

I've had a search around in the C drive and in various Windows/User folders but I can't see anything so I'm sure I'm looking in the wrong place!

Thanks, it would be useful to know how to accesss this for future trouble-shooting.

Regards,
Richard

Hi Richard,

C:\Users\YourName\AppData\Roaming\OneStream\Desktop\Settings.

You will find files in the above path.

Brilliant - thankyou, I can see it now!

VENKAB05
New Contributor II

Thanks everyone for your response.

I do have a "Load Dashboard Server Task" attached to the button which makes sense why it will not work as many pointed out in your comments. I tried in a completely different environment and it works as expected.

But still am curious, i tried to create a new button which doesn't have Load DashB Server Task (environment in which the issue exist) and still it doesnt work. I would have expected it to work if Load  Task was the sole reason behind this.

phollander
New Contributor III

From what I know, the XFLoadDashboardTaskResult object that gets returned on the Load Dashboard Server Task is the only object related to dashboards that allow you to change parameter values upon loading a dashboard. I believe the WcfEventHandler BR (if you are using this) is not generating a Load Dashboard Operation either.

One last thing I can think of, is that you have a parameter set on the Form template level:

Form.PNG

Although the screen indicates you can set Literal Parameter Values, I have also successfully used it with other parameter types. Is this field empty on your Form Template that your dashboard is assigned to?

Regards,
Paul