Showing results for 
Search instead for 
Did you mean: 

Data load for specific time period pulling data from other time periods

New Contributor II

Hi all,

I'm having an issue whereby I'm importing profit and loss actual's data via a csv file into one of the data upload workflow steps we have set up.

However some of the data is being loaded into months it shouldn't be, even though on the in the csv file the data is pointing to the correct time period.

So for example in the upload file, data is put against time periods such as 2023M1, 2023M2 etc. Having imported the data, validated it and loaded it to the reporting cube we have, some of the data is being loaded into 2023M1 and also 2023M2, when on the upload file it's only on there once against 2023M1.

I've checked the transformation rules and everything is set up correctly in terms of translating the import file, so I was wondering if anyone has come across this type of issue before or if anyone has any advice as to where I could look next?

I'm pretty new to OneStream so any help would be much appreciated.




New Contributor II

Are the values being loaded to just to Stage or loaded to a Cube? If the file you are importing has multiple periods (M1, M2, M3...M12) and you are importing just M1 in your Workflow step, it will bring all months into Stage. Would really depend on your Workflow settings.

New Contributor II

Hi, the values are being loaded to the stage, then validated and loaded to a cube. I've tried importing multiple periods, the way we have the stage set up is there's a separate stage for each month, and then in theory once I seed the actuals the values should populate the relevant month.

However as an example in the stage each month has only values relating to that particular month. But when it's loaded to the cube, some of the values are then appearing in 2 months, even though it's only against 1 month,

I've also tried just importing each month separately, but still I'm having the same problem.

New Contributor III

If your DataSource is setup to take the period of the data from the file, and the file contains multiple periods, this will cause the issue you are seeing. If your DataSource is setup to use the "Current DataKey Time" it will ignore the file settings and attempt to load all the records in the file to the period you are importing into. Which setting you should use are dependant on many factors and should be considered closely. But as suggested already, log a ticket with our awesome support team and they should be able to advise you on the best approach, or find someone that can.

New Contributor II

I would suggest opening a ticket so that someone can troubleshoot this with you. Would be good to see "live" what is happening so that we can troubleshoot more easily.

New Contributor

If the amount loaded into two months is the reversal of the first month's amount and only happens in months where you have no data in the following month, see the responses in the following post, as it's very informative and we battled the same issue: