cancel
Showing results for 
Search instead for 
Did you mean: 

Task Scheduler not executing tasks

royari
Contributor

I have scheduled a data management sequence to run every 120 minutes between a specified time range (7 am to 9 am) -- But the data management sequence is not being executed. There are no parameters needed in the data management sequence, and I have confirmed that manually running the sequence works without error. 

When I check the grid view in Task Scheduler, I can see the "Next Start Date/Time" column is correct. However, when the system finally reaches that time, the task is not executed, the "Count" column remains as zero, and the "Next Start Date/Time" column updates to 120 minutes later. I receive no system errors on why the task is not executing.

I have confirmed the scheduling a one time task, or even a daily task works successfully. 

 

Any help on this would be great.

9 REPLIES 9

db_pdx
Contributor III

Hmm, only thing I can think of is the state is disabled.  Edit the job, on the 'Schedule' tab, check that 'Enabled by Manager' is check (is enabled).

I have confirmed that 'Enabled by Manager' is checked. It also says that the 'State' is enable in Grid View. Still no luck.

db_pdx
Contributor III

Have you checked that the Data Management Sequence has the step(s) assigned?  Ive made the mistake of checking that the step itself works, but then forget to assign the steps to the sequence.

Yes I have confirmed that. I have also confirmed that running the sequence manually works. 

db_pdx
Contributor III

And the start month/day/year are all correct as well?  The expiry time is in the future, not the past?  These are probably frustrating questions, but I'm at a loss for what else to check!

Yes those are all correct. Expire time is in the future. I have tested turning off expiration date, and having it expire on several different dates and times. I can see the task scheduled correctly in calendar view and grid view. I can see that Grid view is showing the correct "Next Start Date/Time." but when it finally gets to that time, the sequence does NOT run, but the next start time updates.

Ankit_Shah
New Contributor

May be "data management sequence" needs parameters , can you check that?

rjgoss
New Contributor II

I know this is over four months old now, but, I went through this with OneStream Support recently and there is now a confirmed bug for this issue.  It only presents when you use the To/From time selection in Task Scheduler.

Clifton
New Contributor II

We are currently facing the same issue and we are in 7.1.3.  The odd part about this, is that it works in our dev environment, but not in prod and they are both on the same version.